Thread: Idle issue
View Single Post
Old 08-04-2020, 03:34 PM   #1
dave`12
Registered User
 
dave`12's Avatar
 
Join Date: Sep 2015
Location: Lake Placid florida
Posts: 589
Idle issue

I have an issue that I can't seem to figure out.

I put a Holly Demon carb onto the truck a while back. Since then, I've had the problem that the idle is high until I juke the throttle. I'm pretty sure the problem came with the new carb. But the carb has been on quite sometime just sitting in the garage (about a year) as I was not driving the vehicle. Now I'm recently retired and using it more, so time to address the issue.

Specifically: Truck idles around (I'm guessing 2k, no tach) when I start it up. If I juke the throttle, it will come down to what sounds right. This happens every time I drive the truck hot and cold. So each time I come to a stoplight, I have to juke the throttle for a normal idle. I played with the choke, lean and rich to no avail. I've pulled the throttle linkage (from under the hood) frontwise (which would lower the idle), and it does not move, so I don't think a stiffer idle return spring would help. I sprayed carb cleaner around, but did not find a vacuum leak.

I find it baffling that each time I juke the throttle, it goes down, but won't on it's own.

Truck runs great. Good power, smooth off idle, etc.

By the way, I have aftermarket a/c that works good; and when the a/c is on, the idle seems to do the same thing.

1967 c10. 350cid Holly Street Demon 625 electric choke.

Any help appreciated!
__________________
1967 C-10 4-speed, 350v8
dave`12 is offline   Reply With Quote