The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > General Truck Forums > Electrical

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 08-01-2020, 09:29 AM   #1
jessemthompson
Senior Member
 
Join Date: Nov 2011
Location: Williamsburg, VA
Posts: 838
Tail light issues

I have united pacific LED tail lights. Everything on them functions correctly with the key in the off position, but with the key in the on position with the lights on, the brake lights are stuck on. Turn the lights off and all works well. I have grounded the bed to the frame and cleaned the tail light buckets so they ground to the bed. I am about to run a ground from the tail light buckets to the frame to see if the issue is resolved. Has anyone had this happen?
jessemthompson is online now   Reply With Quote
Old 08-03-2020, 11:49 AM   #2
VetteVet
Msgt USAF Ret

 
VetteVet's Avatar
 
Join Date: Jan 2005
Location: Kalamazoo, Michigan
Posts: 8,480
Re: Tail light issues

This should be an easy fix but you need to tell us what year truck you have cause the circuits are different on the different years. You have to separate the key on and key off circuits because the tail lights and stop lights are on different circuits. The turn lights work with the stop lights but only with the key on.
. What happens when you turn the headlights on with the brakes on and with the key off and what happens when you turn the tail lights on with out the brakes on with the key off.
You might have a battery draw issue when the headlights are on too. It's just too hard to tell with so little details.
__________________
VetteVet

metallic green 67 stepside
74 corvette convertible
1965 Harley sportster
1995 Harley wide glide

Growing old is hell, but it beats the alternative.
VetteVet is offline   Reply With Quote
Old 08-03-2020, 10:21 PM   #3
jessemthompson
Senior Member
 
Join Date: Nov 2011
Location: Williamsburg, VA
Posts: 838
Re: Tail light issues

I originally posted in the 67-72 section and it was moved here. I have a 72 C10. All lights on the truck functions as normal with the lights on and power off. Turn the key on with the headlights on and the brake lights come on instead of the taillights, press the brakes and nothing happens. Turn signals and hazards operate as they should.

Last edited by jessemthompson; 08-03-2020 at 10:30 PM.
jessemthompson is online now   Reply With Quote
Old 08-04-2020, 10:23 PM   #4
VetteVet
Msgt USAF Ret

 
VetteVet's Avatar
 
Join Date: Jan 2005
Location: Kalamazoo, Michigan
Posts: 8,480
Re: Tail light issues

Did the lights all work before you installed the LEDs? If so the wiring at the lights may be crosssed especially if the leds are joined for tail lights and brake lights. What I mean is, the LEDs for the brakes uses more than the LEDs for the tail lights and you may be seeing brake LEDs and Tail LEDs together when you turn the key on. Does turning on just the parking lights not the head lights make any difference?

recheck your wiring and make sure the ground wire is correct on both lights.

It is strange that turning the key on is what makes the difference. That powers the turn signal circuit but not the brakes or tail lights.
__________________
VetteVet

metallic green 67 stepside
74 corvette convertible
1965 Harley sportster
1995 Harley wide glide

Growing old is hell, but it beats the alternative.
VetteVet is offline   Reply With Quote
Old 08-05-2020, 03:01 PM   #5
jessemthompson
Senior Member
 
Join Date: Nov 2011
Location: Williamsburg, VA
Posts: 838
Re: Tail light issues

So today I put an 1157 bulb in the driver side tail light just to test things. It worked like normal. So I know I don’t have enough load or draw on the circuit. So I ordered a second electronic flasher. I will check back in once it arrives and I’ve installed it. If not, I think I’ll have to put a resistor in-line.
jessemthompson is online now   Reply With Quote
Old 08-06-2020, 01:03 PM   #6
jessemthompson
Senior Member
 
Join Date: Nov 2011
Location: Williamsburg, VA
Posts: 838
Re: Tail light issues

Today I wired in an additional 1157 pigtail, put a bulb in it and my lights operate like they’re supposed to. I’ll use this until my electronic flasher shows up. Hopefully that will let me take the additional plug out.
jessemthompson is online now   Reply With Quote
Old 08-13-2020, 08:55 PM   #7
jessemthompson
Senior Member
 
Join Date: Nov 2011
Location: Williamsburg, VA
Posts: 838
Re: Tail light issues

Just to follow up here. I got the electronic flasher in the mail and put it in the truck. I removed the bulb from the extra pigtail I wired in and the problem with the brake lights was still there. I can either leave the bulb in or wire in resistors. Either way I know that not having enough resistance in the circuit was my issue. Thank you vettevetfor your input.

Last edited by jessemthompson; 08-13-2020 at 08:56 PM. Reason: Spelling error
jessemthompson is online now   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:24 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com