The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1988 - 1998 GMT400 Chevy & GMC Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 10-07-2015, 09:58 AM   #1
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Exclamation Help- both turn signal indicators turn on when lights are on

Time for everyone's favorite thing.... Electrical.

I have a 1995 Chevy Silverado K 1500

The problem seems to be simple enough, when I turn my lights on both of my turn signal indicators turn on as well, and it is draining my battery when I am driving with my lights on. I know it sounds like a simple ground issue, but I cannot seem to find where this issue is.

Long story short, the truck has been rebuilt pretty much from the ground up, it has a new motor transmission bunch of stuff done to the brakes and all of the lights on the truck have been swapped out 4 LEDs.

Here is what I have tested so far. I have checked the mass grounds on both sides of the frame, both are good, I have disconnected to the rear harness to see if the backseat issue was coming from the back of the truck, indicator lights were still on even when the back harness was disconnected, I have checked all of the grounds from the battery, all of them are good, & I have checked all of the grounds on the intake manifold all of which are good. I have also replace the alternator to no avail.

There has to be something I am missing? Like I have stated before, all of the lights have been upgraded to LEDs. Also worth noting my light / dimmer switch has been replaced with a new one. If I toggle the switch it seems like the indicator lights flicker a little bit.

Any help is greatly appreciated
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/
JetForceF22 is offline   Reply With Quote
Old 10-08-2015, 03:53 PM   #2
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Re: Help- both turn signal indicators turn on when lights are on

Update: Upon further testing last night I narrowed it down to my marker side lamps on the front of the truck.

If I put a incandescent bulb in my indicator light goes full green like it is on all the time. With the LED's its only a faint green but its still getting back-feed.

Here's where it gets strange. So the Market Light socket has 2 leads, a green lead and a brown wire. The green wire supplies power to the marker light when the lights are on. Not quite sure what the brown wire does. I hooked up the test light to the green wire and grounded the test light which resulted in the marker lamp turning bright. Upon turning on my flashers, the light flashed with no problem and the indicator in the dash was no longer lit when the lights were on.

I preceded to ground the green wire just like I did with the test light. However when the green light was physically grounded with a wire, it shorted and blew the break fuse. Baffled, I tried it again with the test light with no issues. As soon as I used the grounded wire, it blew the fuse again. I tried a few different locations for the ground with the same results. I'm still baffled, so until I can figure out why its doing this I disconnected the bulbs from both of the marker lamps.

Anyone have any suggestions on where to go from here?
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/
JetForceF22 is offline   Reply With Quote
Old 10-08-2015, 09:04 PM   #3
sntrym95
Senior Member
 
sntrym95's Avatar
 
Join Date: Jan 2006
Location: Cleveland, Oh
Posts: 627
Re: Help- both turn signal indicators turn on when lights are on

When you added the LED bulbs, did you put in resistors?
__________________
Mike

Toy list:
1995 GMC Yukon 4dr 2wd 5.7 Vortec conversion, AAM TracRite, Lincoln Mark VIII fan conversion
1979 Mako 23 CC
sntrym95 is offline   Reply With Quote
Old 10-08-2015, 09:07 PM   #4
sntrym95
Senior Member
 
sntrym95's Avatar
 
Join Date: Jan 2006
Location: Cleveland, Oh
Posts: 627
Re: Help- both turn signal indicators turn on when lights are on

http://www.carid.com/articles/what-d...to-my-car.html
__________________
Mike

Toy list:
1995 GMC Yukon 4dr 2wd 5.7 Vortec conversion, AAM TracRite, Lincoln Mark VIII fan conversion
1979 Mako 23 CC
sntrym95 is offline   Reply With Quote
Old 10-09-2015, 08:41 PM   #5
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Re: Help- both turn signal indicators turn on when lights are on

I understand completely well about the differences in voltage between LEDs and incandescent. This is not my problem however, I can live with a hyper flashing. My problem is something is drawing excessive current and draining my battery, and my alternator is not able to compensate for this battery drain. Load resistors essentially negate any voltage drop benefit you may have achieved from using just LEDs alone. Not to mention that load resistors get hot and can harm other components that may be near the load resistor. Not to mention, more wires to cut and more opportunity for electrical errors in the future.

I have a ground issue, or power short somewhere in my system and was hoping anybody had suggestions on where I should be looking for this issuE or any way to troubleshoot my harness to find the culprit.
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/
JetForceF22 is offline   Reply With Quote
Old 10-10-2015, 09:26 PM   #6
dragginmetal
here, just not logged in
 
dragginmetal's Avatar
 
Join Date: Nov 2007
Location: Tx
Posts: 1,011
Re: Help- both turn signal indicators turn on when lights are on

On my side marker lamp, I have brown and blue. Brown gets power from headlight/ Panel dimmer switch. Blue gets power from turn signal/Hazard switch. Neither goes to ground. Both tie into the same colors (blue to blue, brown to brown) on the turning lamp. Do you need the wire diagram?
dragginmetal is offline   Reply With Quote
Old 10-10-2015, 11:55 PM   #7
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Re: Help- both turn signal indicators turn on when lights are on

Quote:
Originally Posted by dragginmetal View Post
On my side marker lamp, I have brown and blue. Brown gets power from headlight/ Panel dimmer switch. Blue gets power from turn signal/Hazard switch. Neither goes to ground. Both tie into the same colors (blue to blue, brown to brown) on the turning lamp. Do you need the wire diagram?
If you have send it over that would help a lot! Thanks for the explanation on the wires. It makes me think something may be bad on the grounds to my running lamps, I'll check the diagram.
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/
JetForceF22 is offline   Reply With Quote
Old 10-11-2015, 08:25 AM   #8
dragginmetal
here, just not logged in
 
dragginmetal's Avatar
 
Join Date: Nov 2007
Location: Tx
Posts: 1,011
Re: Help- both turn signal indicators turn on when lights are on

tmp_18723-EL1268144271.pdf

tmp_18723-HL-589384783.pdf
dragginmetal is offline   Reply With Quote
Old 10-11-2015, 02:17 PM   #9
Cape Codder
Registered User
 
Cape Codder's Avatar
 
Join Date: May 2013
Location: Centerville,Ma.
Posts: 1,219
Re: Help- both turn signal indicators turn on when lights are on

I would think a draw that is killing the bat while the alt is charging would have burnt something out by now. Are you sure the alt is putting out 14 volts
Cape Codder is offline   Reply With Quote
Old 10-11-2015, 02:40 PM   #10
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Re: Help- both turn signal indicators turn on when lights are on

I bought a bran new alternator after reading the voltage at 13.2 with no accessories on. When I put the new one on it immediately read 13.4 and increasing (as the battery was charging) It hovers around 14 now with no accessories, then drops as soon as I turn on my running lights (not headlights) so I figured it had to be something in the electrical system with the lighting.
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/
JetForceF22 is offline   Reply With Quote
Old 10-12-2015, 09:02 AM   #11
speedygonzales
Registered User
 
speedygonzales's Avatar
 
Join Date: Jan 2006
Location: Smithfield, VA
Posts: 1,460
Re: Help- both turn signal indicators turn on when lights are on

When you checked the grounds, did you actually take measurements?

Did you check the ground connection to the indicator lights?

With regard to charging or not charging. If the alternator is working properly and all the connections are made to it correctly and the battery, there is no way anything stock should cause it to not charge correctly. Only added drain could do that. For example a cooling fan for the radiator that runs all the time, or one of those big thumping amps. A short for example, would either blow a fuse or melt a wire. Running voltage through a device that was intended to be there can not do what your suggesting.

Did you check battery/alt voltage at different points? ie. across both battery terminals, then positive battery terminal to frame rail, then positive battery terminal to engine block, Alt output post to frame rail, alt output post to engine block and last alt output post to negative battery terminal? By doing this I discovered a charging problem the dealer missed.

I don't know why your wiring is not matching the drawing. Is the drawing a different year or has your truck wiring been changed, or is the wiring of the truck faded color?

Regardless of wiring color, there is one thing that should be the same. That is, the color of the wire going to the side marker light should match the color of the wire going to the indicator light. Does it match?
__________________
99 Z71 (98 body style)
Pride and joy

Last edited by speedygonzales; 10-12-2015 at 09:09 AM.
speedygonzales is offline   Reply With Quote
Old 10-12-2015, 10:07 AM   #12
dragginmetal
here, just not logged in
 
dragginmetal's Avatar
 
Join Date: Nov 2007
Location: Tx
Posts: 1,011
Re: Help- both turn signal indicators turn on when lights are on

The diagrams are for a 95 1500. I looked at 3 different ones from each yr 88,94,95,98. All have blue, Lt blue, brown. Mostly greens were for horn, headlights, tail lights.

Last edited by dragginmetal; 10-12-2015 at 10:14 AM.
dragginmetal is offline   Reply With Quote
Old 10-12-2015, 02:55 PM   #13
Cape Codder
Registered User
 
Cape Codder's Avatar
 
Join Date: May 2013
Location: Centerville,Ma.
Posts: 1,219
Re: Help- both turn signal indicators turn on when lights are on

The first place to look for wiring issues is any place someone has fooled with the factory harness. The next thing to do would be to try disconnecting circuits till the lights go out. Have you pulled the running light fuse and then switch on the lights to see if they are back feeding from something else. Try unplugging the tail lamp harness in the rear, Look at the front light harness to see if it is pinched between a fender or support bolt. Has the front sheet metal ever been removed due to accident? You could remove the light switch and see if the wires are getting hot with the lights on.
I believe running light wiring should be brown on these trucks. The rear cargo lamp switch is on that circuit also I believe.
Cape Codder is offline   Reply With Quote
Old 10-12-2015, 03:03 PM   #14
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Re: Help- both turn signal indicators turn on when lights are on

Quote:
Originally Posted by speedygonzales View Post
When you checked the grounds, did you actually take measurements?

Did you check the ground connection to the indicator lights?

With regard to charging or not charging. If the alternator is working properly and all the connections are made to it correctly and the battery, there is no way anything stock should cause it to not charge correctly. Only added drain could do that. For example a cooling fan for the radiator that runs all the time, or one of those big thumping amps. A short for example, would either blow a fuse or melt a wire. Running voltage through a device that was intended to be there can not do what your suggesting.

Did you check battery/alt voltage at different points? ie. across both battery terminals, then positive battery terminal to frame rail, then positive battery terminal to engine block, Alt output post to frame rail, alt output post to engine block and last alt output post to negative battery terminal? By doing this I discovered a charging problem the dealer missed.

I don't know why your wiring is not matching the drawing. Is the drawing a different year or has your truck wiring been changed, or is the wiring of the truck faded color?

Regardless of wiring color, there is one thing that should be the same. That is, the color of the wire going to the side marker light should match the color of the wire going to the indicator light. Does it match?
Thanks for the suggestions, I'll have to preform a more detailed analysis with the multi meter. The wiring does match the diagram, now that I have that I'll be able to troubleshoot the issue further. I have a inkling that the harness ground that goes to my dimmer switch might have something to do with it.

The truck sat for 4 years, and the critters had fun with a few of the wires under the hood.

Either way, when I disconnected the marker lamps the indicator lights in the dash turned off, so for the moment they are disconnected.

Also, since you mentioned added voltage draw, I do have a lot of added exterior lights on the truck, but the majority of them are on separate toggle switches, and almost all of them are LED's, so the added draw would be nominal, at best.

It is worth noting though that I don't recall ever having this issues with this prior to the truck sitting.
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/

Last edited by JetForceF22; 10-12-2015 at 03:10 PM.
JetForceF22 is offline   Reply With Quote
Old 10-14-2015, 03:08 PM   #15
speedygonzales
Registered User
 
speedygonzales's Avatar
 
Join Date: Jan 2006
Location: Smithfield, VA
Posts: 1,460
Say what?

Quote:
Originally Posted by JetForceF22 View Post
I have a inkling that the harness ground that goes to my dimmer switch might have something to do with it.
Pretty certain you don't have a ground going to a dimmer switch if it's not a lighted type of switch.

Quote:
Originally Posted by JetForceF22 View Post
Either way, when I disconnected the marker lamps the indicator lights in the dash turned off, so for the moment they are disconnected.
That with what you said earlier, is an indication that the indicator bulbs don't have a good ground and are getting the ground (so to speak) through the marker lights.

Quote:
Originally Posted by JetForceF22 View Post
It is worth noting though that I don't recall ever having this issues with this prior to the truck sitting.
Another indication of missing grounds.
__________________
99 Z71 (98 body style)
Pride and joy
speedygonzales is offline   Reply With Quote
Old 10-14-2015, 10:57 PM   #16
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Re: Say what?

*deleted for double post*
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/

Last edited by JetForceF22; 10-14-2015 at 10:58 PM. Reason: Double Posted... deleting
JetForceF22 is offline   Reply With Quote
Old 10-14-2015, 10:57 PM   #17
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Re: Say what?

Quote:
Originally Posted by speedygonzales View Post
Pretty certain you don't have a ground going to a dimmer switch if it's not a lighted type of switch.

That with what you said earlier, is an indication that the indicator bulbs don't have a good ground and are getting the ground (so to speak) through the marker lights.

The switch is lighted (though barely noticeable at night) when I had the markers in, if I jogged the switch left to right the indicator lights would flutter in dimness (though not much)

That with what you said earlier, is an indication that the indicator bulbs don't have a good ground and are getting the ground (so to speak) through the marker lights.

I'm going to check the grounds off of the marker lights when I have a free moment. Thanks for the feedback
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/
JetForceF22 is offline   Reply With Quote
Old 10-17-2015, 07:23 PM   #18
speedygonzales
Registered User
 
speedygonzales's Avatar
 
Join Date: Jan 2006
Location: Smithfield, VA
Posts: 1,460
Re: Say what?

Quote:
Originally Posted by JetForceF22 View Post
I'm going to check the grounds off of the marker lights when I have a free moment. Thanks for the feedback
NOT the marker lights, although it would be ok to check them. I was referring to the indicator lights you mentioned earlier that I assumed was the indicator bulbs in the dash board.
__________________
99 Z71 (98 body style)
Pride and joy
speedygonzales is offline   Reply With Quote
Old 10-25-2015, 04:36 PM   #19
firebird73
Registered User
 
Join Date: Feb 2013
Location: Brussels,WI
Posts: 15
Re: Help- both turn signal indicators turn on when lights are on

you need led flashers, not Load resistors, I had a similar problem on my car, I put led bulbs in everything and whenever I would hit the brakes my turn signals would light up, so I bought some load resistors and it didn't fix anything, then somebody told me to get an led flasher and it fixed the problem, that was about 6 months ago and i haven't had any problems since.
firebird73 is offline   Reply With Quote
Old 10-29-2015, 05:16 PM   #20
JetForceF22
Registered User
 
JetForceF22's Avatar
 
Join Date: Jul 2009
Location: Westminster, MD
Posts: 207
Exclamation Re: Help- both turn signal indicators turn on when lights are on

Quote:
Originally Posted by firebird73 View Post
you need led flashers, not Load resistors, I had a similar problem on my car, I put led bulbs in everything and whenever I would hit the brakes my turn signals would light up, so I bought some load resistors and it didn't fix anything, then somebody told me to get an led flasher and it fixed the problem, that was about 6 months ago and i haven't had any problems since.
If you can find a LED flasher unit that works with my truck then I would be much obliged.

Mine is a 1995, the last year of the old TBI engines and new year of the updated interior.

My flasher is a 3 pin. (EP28)
Amazon.com: Tridon EP28 Flasher: Automotive Amazon.com: Tridon EP28 Flasher: Automotive

To my knowledge, this is the style of flasher that would be in the trucks from 88-95.

I have tried every 3 pin flasher with this orientation and none of them have solved my hyper-flashing issue. Also my problem is back-feeding, and a flasher unit isn't going to address that (I wish it would!)

Also to note, I've tried the EP29 flasher (same orientation with an extra pin in the center) and that didn't work either. I've tried probably 6 different brands of the EP28 and 3 EP29 Flashers and none of them solved my Hyper Flash.
__________________
1972 3/4 Ton Cheyenne Super, 350ci 650 cfm Edelbrock 4bbl Performer AVS, Edelbrock Torquer intake manifold, Headman Longtube Headers to 2 1/2in cutouts to 3 inch flowmaster super 40's true dual. 4.10? Rear SM-465/205 transfer case. Now this one is busted!! http://s59.photobucket.com/albums/g2...k/1972 Pickup/
1995 K1500 Silverado 5.7L 350 TBI with 1in swirl torque spacer, Flowtech shorty headers, 3 inch collectors to y pipe going to 3in highlfow cat converter, single offset passenger side outlet, full 3 inch setup from collectors. Edelbrock High Flow 255LPH/67GPH Fuel pump, adjustable fuel pressure regulator and gauge, running at about 18psi. 3.73 Rear 4L60-E 4 speed auto (Rebuilt)http://s59.photobucket.com/albums/g2...1995%20Pickup/

Last edited by JetForceF22; 10-29-2015 at 05:24 PM.
JetForceF22 is offline   Reply With Quote
Reply

Bookmarks

Tags
1995, backfeed, electrical issue, indicator, turn signals

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:14 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com