The 1947 - Present Chevrolet & GMC Truck Message Board Network

The 1947 - Present Chevrolet & GMC Truck Message Board Network (https://67-72chevytrucks.com/vboard/index.php)
-   The 1988 - 1998 GMT400 Chevy & GMC Pickups Message Board (https://67-72chevytrucks.com/vboard/forumdisplay.php?f=12)
-   -   Dead (https://67-72chevytrucks.com/vboard/showthread.php?t=818533)

crsgmc 02-17-2021 07:15 PM

Dead
 
I have a 1996 GMC K1500 5.7. I just got home with my truck on the back of a flat bed tow truck. I left home drove about 20 miles. Went into a store, came out and was headed home. Truck had been running perfect up until that time. Started up the on ramp and it totally died. Got it backed of onto the shoulder and tried to restart. It would not start and acted like it wasn't even trying. You can hear the fuel pump prime. I checked for codes and there were no listed codes. I was sure there would be a code a fast as it died. I did try to start it again after the tow truck left and it was the same. I have been rebuilding this truck the last couple of years and a lot of the parts have been replaced:

New crate engine
New injectors, the new non popit ones.
New distrubutor
New wires and coil
New spark plug
New fuel filter
New Battery
New O2 sensors

Any ideas, I am not an expert mechanic, but I have done a lot of work on this truck. Including all of the above. It has never been in for service, I have done everything. Last problem a couple of months ago it would not start and it turned out to be the starter relay was bad. Any help I can get would be great

sntrym95 02-17-2021 08:08 PM

Re: Dead
 
I would check for spark first. That's easy. If you have it, then it's a fuel issue. Not likely. Assuming you don't have spark, I'd test the coil and the crank position sensor. If those test fine, I'd go for the dizzy cap. Depending on which brands you bought, brand new may not be quailty.

crsgmc 02-18-2021 09:07 AM

Re: Dead
 
I read your reply and it got me thinking. The crank position sensor is new (two years and maybe 10000 miles). I replaced it when I put the new engine in. The way that it died, was like you threw a switch, one second it was running fine the next it was dead. What got me thinking was when you try to start it, it goes really fast and then stumbles. Not like it is about to start, but sounds like diesel engine. Sitting on the edge of the ramp, I thought it sounded like the timing was way off. I checked all the wires from distributor and made sure the distributor had not come loose. I am thinking it might be the crank position sensor, I will check for spark and remove the crank position sensor and look for testing procedure. Has anyone had a bad crank position sensor, What were the symptoms. Thanks for the reply.

crsgmc 02-18-2021 09:57 AM

Re: Dead
 
Does it have a camshaft sensor and a crankshaft sensor, or is it the same sensor by a different name?

61_FL_Apache 02-18-2021 01:54 PM

Re: Dead
 
There is a cam sensor in the distributor.
The crank sensor is behind the harmonic balancer up front.
Are you getting any CEL codes?

crsgmc 02-18-2021 02:35 PM

Re: Dead
 
I checked for codes and it did not have any codes. The crankshaft position sensor came in the new gm crate engine. It is three years old and maybe 10000 miles

61_FL_Apache 02-19-2021 09:22 AM

Re: Dead
 
check for fuel pressure. Can you hear your fuel pump kick on when you turn the key?

crsgmc 02-19-2021 09:59 AM

Re: Dead
 
Yes the pump is priming normally. I don't have a pressure gauge, will need to get one. Can you use a tire gauge to get a rough reading?

61_FL_Apache 02-19-2021 02:26 PM

Re: Dead
 
No. That wont fit. One of these kits will work. You can press the center of the shrader valve to see if fuel is coming out under pressure. It will make a mess so beware.

https://www.ebay.com/itm/35321631512...SABEgLUL_D_BwE

What about the connection to the fuel injection spider on the top of the manifold? make sure that is making a good connection.

Did you check for spark yet?

gmc684x4 02-19-2021 09:33 PM

Re: Dead
 
Have you pulled the starter relay try bump start it with key on in park
Is your security light staying on these trucks have funky antitheft modules that can cause a non start problem

crsgmc 02-20-2021 11:43 AM

Re: Dead
 
There is no security light. The 1996 trucks did not have pass lock. I think that started in 1997. There is no parking, it is a manual transmission. The clutch cut off switch prevents the starter from working. My starter will turn over, but it will not start. I have ordered a new crankshaft position sensor. From what I have found sometimes they start to go bad resulting in poor running and starting. Sometimes they just go dead. In this condition the computer will not "send" spark to the engine. That is the way it acted when it died running down the road. I will install it and if this doesn't work I will have to do more testing. I will start with spark and then fuel pressure. I will let you know how it goes.

TexasLS1 02-25-2021 02:54 AM

Re: Dead
 
Just read your thread - any luck yet?

crsgmc 02-25-2021 05:19 PM

Re: Dead
 
I ordered the part but it got delayed in shipping. I should get it today based on tracking. Installing this laying out in the snow at 20 degrees is not going to be fun. There is no way to get the truck back into the garage with an uphill driveway. I really.... really hope this fixes it, because I cannot come up with anything else that may have caused this. There are other things but I have replaced many of the parts when I replaced the engine.

TexasLS1 02-25-2021 05:59 PM

Re: Dead
 
Bleh yeah I didn’t think about the snow and cold up there right now, no fun. Keep us updated on what happens. If no luck, have the parts store test your Ignition Control Module, and you can rent a loaner Fuel Pressure Test Kit (Autozone does both for free). Sounds like you’re getting some fuel and spark at least though, since it will stumble a bit.

Hopefully you’re on the right track with the crank sensor!

61_FL_Apache 02-26-2021 08:59 AM

Re: Dead
 
Speaking of Ignition Control Module. Check the wiring going to it. I had to replace that cable on my daughters Blazer with a 4.3. Its the same cable you have.

We figured that out by accident. The pigtail appears to look fine, but when you start moving the wires around at the connector it would either start and run or no start. you can find this pigtail at Advance Auto Parts.

Have someone move the wires around at the connector while you are cranking it.

crsgmc 02-26-2021 04:23 PM

Re: Dead
 
Just came inside, not that cold (36) but 25 to 30 miles an hour wind. I replaced the crankshaft position sensor, it did nothing. I looked in my repair log and I replaced the coil and Ignition Module 1-15-19 both Ac Delco. The only reason that I replaced them is it was original parts (the coil is riveted on to the bracket). Wanted to see if I could smell gas at the tailpipe, but the wind is so strong I am not sure it would be a good test. I don't have anyone to turn the key to check for park, so I am going to rig it up and record it with my phone while I turn it over. Can't do that now the wind is blowing too hard. Because of the way it just totally shut down and now won't restart, I wonder if the oil pressure sensor went bad and it shut the truck down. The distributor I put in was a top street performance, did not like the plastic Ac Delco. From my log it appears that I did not replace the oil pressure sensor when I replaced the engine. So the oil pressure sensor is likely 25 years old and 260,000 some miles. I can look at the cap and rotor, but I would think this would not just totally fail. I know you can get new bad parts, but it is not that common. Will check spark when the wind dies down.

Second Series 02-26-2021 05:26 PM

Re: Dead
 
Are the fuse sockets tight? I got an '88 truck that would not start sometimes. I put my hand on the fuse panel and the truck started right up. The fuse to the ECM, temp, and fuel pump practically fell out when I touched it. The fuse socket had lost tension. I found several loose sockets, so I picked up a used fuse panel and replaced the sprung sockets. I have also read about the bulkhead connector behind the fuse panel can get corroded.

Just call me Sean 02-26-2021 10:00 PM

Re: Dead
 
Cool, we're playing the guessing game. I want to play. I guess the distributor since you didn't buy AC Delco.

crsgmc 02-27-2021 11:37 AM

Re: Dead
 
I have been thinking the same thing. I can't count all the threads, where the cap and or rotor ended up being the problem. I think it is kind of strange that it would just die and never restart again. I need to take a look inside the distributor to see if I can see any problems. The coil and ICM are really new and Ac Delco. Hard to believe that either part failed this soon with very few miles. I would think a distributor if bad might make it run poor....backfire, missfire etc, but to just totally shut down? Weather here is not good, hoping for better weather in the next couple of days to work on it.

One more thing from the above post by me. From what I can tell a bad oil pressure sensor does not shut down the engine, so that is not the problem.

Just call me Sean 02-27-2021 02:54 PM

Re: Dead
 
I was half joking. Guessing can get expensive, unless you have a pile of extra parts laying around like I do. When mine died I checked for spark, there was none. Then I started checking the signal wires. Everything worked up to the coil. I did suspect the coil, because someone changed it with a "performance" one. I was cheap though, I didn't replace it with an AC Delco one.

crsgmc 02-28-2021 06:15 PM

Re: Dead
 
I always like it when people post the symptoms and the final solution. Many times it goes on for pages and then nothing. I "think" I have it figured out. I pulled the fuel pump relay to prevent more gasoline dumping in and mixing with the oil. I tested for spark coming out of the coil. I used jumper cables so I could get the jumper spot high enough so that I could see it out the front window while cranking. I need to buy an inline spark tester. I got good spark from that position. This likely means that the ICM and the coil are good. I then tested one of the spark plugs coming out of the distributor. I know the ground was good because I was using the same starter cable and ground spot. I could not see any spark. I double checked the connection to make sure the ground was good. I also know that I could see the spark from the coil, so I should have been able to see it from the distributor. But you never know. At this point I have ordered a new cap and rotor. That should arrive by this Friday, so Saturday I will install. Decided not to take the old one out until the new one arrives. Will check back after I confirm that the truck will run. I did order a fuel line pressure kit, in case, this is not the problem. If it does not work, I will buy an inline spark tester and test it again. If that confirms there is spark, I will have to keep looking.

pwdcougar 03-02-2021 05:53 PM

Re: Dead
 
Quote:

Originally Posted by crsgmc (Post 8886738)
I always like it when people post the symptoms and the final solution. Many times it goes on for pages and then nothing. I "think" I have it figured out. I pulled the fuel pump relay to prevent more gasoline dumping in and mixing with the oil. I tested for spark coming out of the coil. I used jumper cables so I could get the jumper spot high enough so that I could see it out the front window while cranking. I need to buy an inline spark tester. I got good spark from that position. This likely means that the ICM and the coil are good. I then tested one of the spark plugs coming out of the distributor. I know the ground was good because I was using the same starter cable and ground spot. I could not see any spark. I double checked the connection to make sure the ground was good. I also know that I could see the spark from the coil, so I should have been able to see it from the distributor. But you never know. At this point I have ordered a new cap and rotor. That should arrive by this Friday, so Saturday I will install. Decided not to take the old one out until the new one arrives. Will check back after I confirm that the truck will run. I did order a fuel line pressure kit, in case, this is not the problem. If it does not work, I will buy an inline spark tester and test it again. If that confirms there is spark, I will have to keep looking.

Got an update? Hopefully it's running again and you forgot to post the solution!

Paul

crsgmc 03-02-2021 06:13 PM

Re: Dead
 
Waiting on the part, should be here in two to three days. I am kind of anxious to get the cap and rotor off to see if I can see any problem. That distributor was new when I installed the crate engine. It only has 14000 miles on it. It is a Top Street Performance (made by MSD).

pwdcougar 03-02-2021 06:20 PM

Re: Dead
 
Quote:

Originally Posted by crsgmc (Post 8887710)
Waiting on the part, should be here in two to three days. I am kind of anxious to get the cap and rotor off to see if I can see any problem. That distributor was new when I installed the crate engine. It only has 14000 miles on it. It is a Top Street Performance (made by MSD).

Dang

I was hoping you would have gotten the part by now!

Paul

sntrym95 03-03-2021 06:55 AM

Re: Dead
 
Quote:

Originally Posted by crsgmc (Post 8887710)
Waiting on the part, should be here in two to three days. I am kind of anxious to get the cap and rotor off to see if I can see any problem. That distributor was new when I installed the crate engine. It only has 14000 miles on it. It is a Top Street Performance (made by MSD).

A lot of new parts, especially aftermarket, are junk these days. ChevyTech and speedygonzales can attest to that, as can I. Stick with OEM stuff as much as possible, but even some of that is not so great. A lot of the Vortec dizzy caps are aluminum which will only work for a little while.

For electric parts, I usually go with ACDelco or Standard since Standard makes a lot of the parts for ACD. Here is that dizzy cap from Summit if the one you ordered doesn't have brass terminals: https://www.summitracing.com/parts/a...ukon/year/1996


All times are GMT -4. The time now is 12:37 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com