The 1947 - Present Chevrolet & GMC Truck Message Board Network







Register or Log In To remove these advertisements.

Go Back   The 1947 - Present Chevrolet & GMC Truck Message Board Network > 47 - Current classic GM Trucks > The 1973 - 1987 Chevrolet & GMC Squarebody Pickups Message Board

Web 67-72chevytrucks.com


Reply
 
Thread Tools Display Modes
Old 05-10-2021, 08:14 AM   #1
bigschuss
Junior Member
 
Join Date: Nov 2016
Location: Savoy, MA
Posts: 61
Can Somebody Tell Me What I Broke - Water Temp. Sender?

The PO of my 1984 K5 with a 305 had an aftermarket water temp. sender installed. It wasn't working and I was trying to remove it and something broke. Not really sure what my next step is.

This is what it looked like.



When I was trying to loosen the smaller nut that held the sender in place the larger fitting snapped off.






This is what I've got now...but I am not really sure what this is. Is that the remains of the larger adapter that is threaded onto a small fitting on the block?

Thanks in advance for any help.

bigschuss is offline   Reply With Quote
Old 05-10-2021, 09:27 AM   #2
v30crewcab
Registered User
 
v30crewcab's Avatar
 
Join Date: Apr 2012
Location: Chatt Tn
Posts: 808
Re: Can Somebody Tell Me What I Broke - Water Temp. Sender?

just part of the adapter. ez out and move on. its just an aftermarket temp gauge.
__________________
88 military v30 crewcab shortbed
5.9 cummins, nv4500, 205
http://67-72chevytrucks.com/vboard/s...d.php?t=522535
v30crewcab is offline   Reply With Quote
Old 05-10-2021, 10:02 AM   #3
bigschuss
Junior Member
 
Join Date: Nov 2016
Location: Savoy, MA
Posts: 61
Re: Can Somebody Tell Me What I Broke - Water Temp. Sender?

Quote:
Originally Posted by v30crewcab View Post
just part of the adapter. ez out and move on. its just an aftermarket temp gauge.
Thanks v30crewcab. Appreciate it. So that adapter piece is threaded into the opening in the block...great. Wasn't quite sure what was going on. I'm on it.
bigschuss is offline   Reply With Quote
Old 05-12-2021, 07:34 AM   #4
TKCR
Senior Member
 
TKCR's Avatar
 
Join Date: Oct 2014
Location: Ohio
Posts: 5,341
Re: Can Somebody Tell Me What I Broke - Water Temp. Sender?

I had that also on my truck when I bought it. Had an aftermarket temp sensor & gauge. It didnít work, so I took it out and put the correct sensor in the block. Found the green wire that was supposed to be on the temp sensor just hanging in the engine room. And guess what? The stock temp gauge was working. Not sure why someone would go to that trouble.
And from the pic of the interior gauge, you can see they also had a radio mounted under the dash also. So I took that out and installed a Custom Auto Sound in place of the stock radio. So Iím thinking they added that radio because the stock one didnít work anymore. But after just doing the temp sensor, I went ahead and hooked the stock radios wires back up, and the stock radio did work! But I went ahead and installed the Custom Auto Sound unit, since I already had it all unpacked, ready to install.
Attached Images
  
TKCR is offline   Reply With Quote
Old 05-12-2021, 08:36 AM   #5
bigschuss
Junior Member
 
Join Date: Nov 2016
Location: Savoy, MA
Posts: 61
Re: Can Somebody Tell Me What I Broke - Water Temp. Sender?

Quote:
Originally Posted by TKCR View Post
I had that also on my truck when I bought it. Had an aftermarket temp sensor & gauge. It didnít work, so I took it out and put the correct sensor in the block. Found the green wire that was supposed to be on the temp sensor just hanging in the engine room. And guess what? The stock temp gauge was working. Not sure why someone would go to that trouble.
And from the pic of the interior gauge, you can see they also had a radio mounted under the dash also. So I took that out and installed a Custom Auto Sound in place of the stock radio. So Iím thinking they added that radio because the stock one didnít work anymore. But after just doing the temp sensor, I went ahead and hooked the stock radios wires back up, and the stock radio did work! But I went ahead and installed the Custom Auto Sound unit, since I already had it all unpacked, ready to install.
Thank you. I can't quite get the remains of the fitting to budge yet. I hit it with some PB Blast and am trying gently with an EZ Out. I also found the live wire that goes to the old temp sender and am hoping that my factory gauge works once I install the new sender.

I also have an aftermarket oil pressure sender that I am going to replace. I can't find that wire though. I heard it's a tan wire.
bigschuss is offline   Reply With Quote
Old 05-12-2021, 09:05 AM   #6
Dead Parrot
Registered User
 
Join Date: Aug 2012
Location: Oklahoma City, OK
Posts: 1,819
Re: Can Somebody Tell Me What I Broke - Water Temp. Sender?

Might check the driver's side head. That is a common location for the stock temp sender. As seen in TKCR's pic. Be advised that a lot of aftermarket replacements for the OEM sender have different resistance curves then the original. Often results in poor gauge readings. There are many threads on this forum on the subject.

The stock oil sender is/was next to the firewall on the driver's side of the distributor. Not the easiest location to get to. The sender wire may be paired with a wire that goes to the electric choke. It was fairly common to have the oil pressure sender also have a simple on/off switch to allow choke heating current once there was engine oil pressure.
Dead Parrot is offline   Reply With Quote
Old 05-12-2021, 12:25 PM   #7
TKCR
Senior Member
 
TKCR's Avatar
 
Join Date: Oct 2014
Location: Ohio
Posts: 5,341
Re: Can Somebody Tell Me What I Broke - Water Temp. Sender?

Hereís another pic of the wire now. I have it marked on the way to the sensor. I have the green wire in a heat resistant loom.
Attached Images
 
TKCR is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:22 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 1997-2020 67-72chevytrucks.com